新闻中心

DZ安装不适合的插件引起应用报错提示“空间不支持curl”

作者 / 时间 2014-04-08 18:18:14

对于使用过Discuz这个程序的站长来说,想必都用过其插件功能。但是今天无忧主机小编需要跟大家说下, 并不是所有的插件都适合在虚拟主机的环境下进行安装的。今天无忧主机小编就遇到一个使用Discuz建站的客户,他急匆匆的跑过来说网站安装不了插件了,在后台开启应用,并安装百度登陆插件的时候提示“curl函数被服务器管理员关闭,并且php_openssl.dll扩展也被关闭,无法继续使用,请联系空间商。”   [caption id="attachment_13782" align="alignnone" width="613"]discuz报错 discuz报错[/caption] 关于这个curl函数,无忧主机小编很清楚服务器是开启了的,但是客户跑过来说需要开启,我告知客户后,详细的了解了事情的来龙去脉,总算知道问题出现在哪里。 原来客户在安装百度登陆插件前,因为好奇,安装过一个名叫“【CSU】虚拟主机”的DZ插件。 无忧主机小编在仔细研究了这个插件之后,发现其功能并不适合安装在虚拟主机下。这个应用是用来出售虚拟主机用的一款应用,可以设置在论坛挂出产品,而这款应用就是设置虚拟主机产品的参数用的。所以,要安装这个插件,需要运行环境拥有服务器文件修改权限。显然,虚拟主机是没有这个权限的。当然,一般discuz站长用不上这种类型的插件。 最后无忧小编通过恢复备份帮客户解决了这个问题。 在这里无忧小编建议各位站长们对一个插件的功能不了解时,建议不要随意安装,要安装的话也建议备份一下空间数据。很多插件有时候是会引起不必要的问题出现的。 相关文章推荐阅读: DISCUZ!X2.5如何开通云平台 全新DISCUZ X3.0论坛图文安装教程 DISCUZ如何设置游客(未登录会员)可以预览图片!

本文地址:https://www.51php.com/discuz/13781.html

1
1
1
1
1
1
1