新闻中心

wordpress升级到最新4.4版本安装报错解决方法

作者 / 时间 2015-12-30 17:51:32

Wordpress这款开源程序想必站长朋友们都不陌生了,这款开源程序后台功能多,开源插件也多,开源的主题当然也很多,站长朋友们使用它做企业站或者搭建个人博客搭建起来都十分方便。小编今天说的是这款开源程序又升级了,已经从4.3.1版本升级到了最新的4.4版本了,这款开源的博客系统频繁的升级后的确又多了很多功能,特别是安全方面和以前相比更加完善了。今天有一位站长朋友购买了无忧独立IP空间安装wordpress最新4.4版本的时候居然报错了。那么是什么原因导致的呢?小编仔细对比了4.4版本和没有升级之前的4.3版本的程序文件发现很多都不一样了,但是导致主要报错的还是CURL函数的问题。那么该怎么去解决呢?小编下面来总结下处理方法。 (一)在wordpress4.3版本的时候,安装报错如果是CURL的问题,那么只要找到/wp-includes/class-http.php的319行代码:

$request_order = apply_filters( 'http_api_transports', array( 'curl', 'streams' ), $args, $url );
修改为以下代码:
$request_order = apply_filters( 'http_api_transports', array( 'streams' ), $args, $url );
也就是去掉括号中的'curl', 这几个字符。 (二)Wordpress4.4最新版本安装报错也是CURl问题,由于程序升级后修改CURL的控制代码也做了改动。修改方法: 找到/wp-includes/class-http.php的309行行代码:
$transports = array( 'curl', 'streams' );
修改为:
$transports = array( 'streams' );
同样也是去掉括号中的CURl字符,位置和控制代码都做了修改,因此很多朋友都找不到的。小编再此都分别总结下。希望以上方法可以帮到有需要的站长朋友们哦。 无忧主机相关文章推荐阅读: WORDPRESS教程:更换域名后需要注意的几点 WORDPRESS从本地搬家到PHP空间文章乱码问题思考 WORDPRESS教程:解决文章ID不连续和修改自动保存文章时间间隔

本文地址:https://www.51php.com/wordpress/21259.html

1
1
1
1
1
1
1