Warning: Invalid argument supplied for foreach() in /www/wwwroot/51php.jxatkj.com/wwwroot/wp-includes/script-loader.php on line 2678

Warning: Use of undefined constant WP_RP_STATIC_BASE_URL - assumed 'WP_RP_STATIC_BASE_URL' (this will throw an Error in a future version of PHP) in /www/wwwroot/51php.jxatkj.com/wwwroot/wp-content/plugins/wordpress-23-related-posts-plugin/init.php on line 388

Warning: Use of undefined constant WP_RP_STATIC_BASE_URL - assumed 'WP_RP_STATIC_BASE_URL' (this will throw an Error in a future version of PHP) in /www/wwwroot/51php.jxatkj.com/wwwroot/wp-content/plugins/wordpress-23-related-posts-plugin/init.php on line 415

前段时间无忧主机香港独立IP空间用户的论坛升级discuz x3.0出现一个问题,就是论坛的QQ的图标后面出现一串英文: !connect_viewthread_share_to_qq,如下图

!connect_viewthread_share_to_qq

!connect_viewthread_share_to_qq

关于这个问题,之前无忧小编在DZ论坛上也看到过,很多热心的网友提供了大量的解决方法,但是都无法奏效,最后面有一个大神提供了一系列的方法都没解决。这个问题说起来也不是个大问题,就是影响了论坛的美观,功能其实还是正常的。

说起来这个是官方的一个bug,这是因为QQ互联插件增加语言包导致的,但官方应用中心没有X3版本的QQ互联插件,没法进行更新修复,下面无忧小编提供一个帖内出现!connect_viewthread_share_to_qq 的两个解决方法。
第一个方法是修改一个文件的属性即可,找到\source\plugin\qqcnnect\discuz_plugin_qqconnect.xml这个文件,修改下面代码:
<item id=”version”><![CDATA[1.17]]></item>
修改为:
<item id=”version”><![CDATA[1.18]]></item>
然后进入后台 应用 系统应用 QQ互联插件后面 更新 即可解决。

另一个方法是一位DZ论坛的网友提供的方法,就是很简单的覆盖文件
把spacecp.inc.php覆盖到/source/plugin/qqconnect/下,
把module.htm覆盖到/source/plugin/qqconnect/template/,
点击下载修复qq报错论坛文件
无忧小编已经对这个文件做了优化,站长们只需要直接解压后用FTP工具上传即可,不过这个方法是很多网友评论可行的,小编用上面的方法解决问题后也没去亲自试验,不过看评论都是成功了的,所以也拿出来和大家分享,同时优化了站长的使用步骤。只是使用别人的源码需要注意哈。
同时给个温馨提醒,覆盖网站源文件,记得要备份哦。

无忧小编在处理售后问题时,看到蜗牛哥哥发了个大哭的表情过来给我,那心情是相当的悲伤,上次的应用中心进不去,被小编解决,一一对应诊断工具内的IP地址后完成,刚经过一番询问过后,他的DZ论坛后台又出现了新的问题,跑过来就是求解决,既然幸福已经到来,无忧主机小编就义不容辞的收下了。

翻页