新闻中心

ecshop在php5.3环境下安装模板出现includes/lib_main.php on line 1329错误提示的解决方法

作者 / 无忧主机 时间 2017-02-08 18:13:23

站长朋友们对ecshop这个开源商城源码并不陌生,目前现在很多站长朋友都是喜欢使用这款源码程序来搭建自己的商场,但是就是有一位php空间用户,他的php版本是5.3以上版本,在选择了一款比较心意的模板的时候,安装的时候就出现了问题,既然报错includes/lib_main.php on line 1329错误的提示,刚开始是认为可能是程序的出错,于是找到了该行代码,进行了查看发现并没有啥问题,于是站长朋友去咨询了官方,然后官方帮助处理之后无忧主机小编就查看了一下,果然这段代码是修改了,下面无忧主机小编就作为一个小小的解释吧。 原因还是出现在php版本5.3的问题上,站长朋友们都是知道的 开源的源码程序几乎最好的支持还是在php5.2版本,那么出现上面所报错的提示原因就是在于php 5.3版本兼容问题导致函数参数传递问题。下面无忧主机小编就给出两种方案: 1、更简单,最近直接的方案就是把php版本更换到5.2版本的即可解决掉这个问题。 2、修改代码的操作: 首先是进入到我们的会员中心---主机管理--控制面板---文件管理,如图1所示: ecshop在php5.3环境下安装模板出现includes/lib_main.php on line 1329错误提示的解决方法 其次就是找到我们的根目录,然后找到includes/lib_main.php,如图2所示: ecshop在php5.3环境下安装模板出现includes/lib_main.php on line 1329错误提示的解决方法 点击编辑,ctrl+f进行查找如下代码:

$ext = end(explode('.', $tmp));
如图3所示: ecshop在php5.3环境下安装模板出现includes/lib_main.php on line 1329错误提示的解决方法 然后把以上代码替换为以下代码:
$extsub=explode('.', $tmp);
$tmp=end($extsub);
如图4所示: ecshop在php5.3环境下安装模板出现includes/lib_main.php on line 1329错误提示的解决方法 就这样我们就轻松的解决掉了includes/lib_main.php on line 1329错误提示。 温馨提示:该技术解决方案的是由无忧主机客服为我们空间客户处理该问题时提供的处理方法,确保在无忧主机能完美实现,因服务较多,客服繁忙,其他主机我们没有过多精力进行大范围测试,不能确保所有虚拟主机都能完美处理,请您理解!
无忧主机提供365天*24小时全年全天无休、实时在线、零等待的售后技术支持。竭力为您免费处理您在使用无忧主机过程中所遇到的一切问题! 如果您是无忧主机用户,那么您可以通过企业QQ【800088151】、售后QQ【网站最下端有】、旺旺【锋讯企业】、400-655-0080免费电话、后台提交工单这些方式联系无忧主机客服! 如果您不是我们的客户也没问题,点击页面最右边的企业QQ在线咨询图标联系我们并购买后,我们为您免费进行无缝搬家服务,让您享受网站零访问延迟的迁移到无忧主机的服务! 无忧主机相关文章推荐阅读: ECSHOP后台功能之杂志管理介绍 ECSHOP后台功能之云服务中心介绍 ECSHOP后台功能之邮件队列管理介绍

本文地址:https://www.51php.com/ecshop/24641.html

1
1
1
1
1
1
1