香港独立IP空间
香港php空间
美国php空间
域名注册

MySQL是一种关联数据库管理系统,关联数据库将数据保存在不同的表中,而不是将所有数据放在一个大仓库内,这样就增加了速度并提高了灵活性。MySQL所使用的SQL语言是用于访问数据库的最常用标准化语言。MYsql的特点为体积小、速度快、总体拥有成本低,尤其是开放源码这一特点,一般中小型网站的开发都选择MySQL作为网站数据库。由于其社区版的性能卓越,搭配PHP和Apache可组成良好的开发环境。Mysql管理工具很多在很多IDC企业一般都是会选择phpmyadmin这款程序来管理数据库。很多站长选择国外开源程序是为了安全,与稳定性的考虑。今天无忧主机小编将给大家介绍由于Mysql版本过低导致phpmyadmin导入Magento的数据库报错的介绍。
phpmyadmin导入Magento的数据库报错如下:
MySQL 返回:#1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘USING BTREE,KEY `FK_TAG_FIRST_CUSTOMER_ID_CUSTOMER_ENTITY_ENTITY_ID` (`first_’ at line 7
解决方案如下:
查找SQL文件

PRIMARY KEY (`tag_id`) USING BTREE 替换成 PRIMARY KEY USING BTREE (`tag_id`)

在查找:

PRIMARY KEY (`tag_relation_id`) USING BTREE 替换成 PRIMARY KEY USING BTREE (`tag_relation_id`)

总结:以上解决方案是因为SQL版本过低,但是有不想更换MYSQL版本,只需通过以上方法修改即可。无忧主机提供的所有php虚拟主机是完美支持所有大众php程序,请个位站长放心使用。
无忧主机相关文章推荐阅读:

MAGENTO文件模板介绍

开发MAGENTO模板先知道

如何调用MAGENTO的静态块

MAGENTO搬家的时候导入数据库表报错问题解决

本文地址:http://www.51php.com/magento/19023.html

喜欢本文或觉得本文对您有帮助,请分享给您的朋友 ^_^

阅读本文的人还阅读:


搜索技术文档