香港独立IP空间
香港php空间
美国php空间
域名注册

当您在安装drupal的时候可能会遇到一个问题,错误提示信息如下。

Client does not support authentication protocol requested by server; consider upgrading MySQL client.

其实这个问题不是drupal的问题,而是数据库的问题,但在安装的过程中也会遇到,那今天无忧主机小编(www.51php.com)就带大家来看看mysql官网对这个问题,而这个问题是因为mysql 4.1以上的版本认证用的是基于一种新的形式的哈希算法密码,而这与老版本的客户端是不兼容的。

而解决这个问题,您可以尝试以下的方法。

●升级数据库客户端的所有程序到mysql 4.1.1版本以上。

●当试图连接到4.1.1以前的版本呢,用一个帐号必须为也为4.1.1以前版本的密码形式。

●重置所有用户密码为4.1之前的形式,当然客户端用的是4.1以前的版本。这可以通过SET PASSWORD语句和OLD PASSWORD()函数来实现。

mysql>SET PASSWORD FOR

-> ‘some_user’@’some_host’ =OLD_PASSWORD(‘www.51php.com’);

此外还需要用到UPDATE和FLUSH PRIVILEGES。

在’51php’中替换为您想要的密码,当然,Mysql并不会告诉您原始的密码是多少。

当然,以上方法来自mysql官网。我们还是回到drupal官网来看一下这个问题的解决方案吧。而我们下面说到的问题需要您有一个较新版本的phpmyadmin和足够的权限。

1、登录phpmyadmin后选择权限选项。

2、编辑您用来链接drupal数据库的用户。

3、拉下来,会有一个“修改密码”的选项。

4、输入一个密码

5、重要!在有显示密码哈希的地方选择“mysql 4.0”兼容。

6、选择执行。

改完后就不会出现错误了,放开心的去享受您的drupal之旅吧。当然在无忧主机(www.51php.com)的php虚拟主机下是不用担心这些问题的。

更多drupal中文教程

无忧主机原创:drupal图文安装教程

无忧主机原创:三分钟教会您安装drupal主题

无忧主机原创:三分钟快速安装Drupal图文解释drupal模块安装指导教程

 

纯Linux环境下高端免备案【香港独立IP地址】php空间,仅仅只需199元一年起。商务中国域名核心代理直销50元注册国际顶级域名

本文地址:http://www.51php.com/drupal/9198.html

喜欢本文或觉得本文对您有帮助,请分享给您的朋友 ^_^

阅读本文的人还阅读:


搜索技术文档