香港独立IP空间
香港php空间
美国php空间
域名注册

建站的朋友应该都对php版本有一定的了解。随着版本更新换代,php版本也水涨船高。目前最新的php版本已经出到php5.5了。Discuz程序对php版本的需求并不高,以目前最新的版本discuz!X3.2为例,只需要php5.2版本就可以完美支持了。无忧主机php虚拟主机也是有php5.2和5.3两个版本供大家选择。然而有些站长朋友以为越是新的版本就越好,所以一旦有了新的php版本,自己就会去更新。这不,无忧主机小编就遇到一位站长朋友这样的问题:

这位朋友在别处购买了一个空间,php版本为5.4,接着安装了一个discuz程序。然后这位朋友在后台安装了一个zend版本校验插件,如图所示:

dz 2015 10 26 1 300x89 Php版本过高导致discuz验证文件无法通过验证解决办法

然而在安装过后,这位朋友发现,无法通过验证,如下图:

dz 2015 10 26 2 300x117 Php版本过高导致discuz验证文件无法通过验证解决办法

遇到这样的问题,小编首先想到的是:会不会是这个zend校验文件上传的时候出现的问题呢?于是小编尝试用二进制的方式上传了这个插件,并没有解决问题。

问题很奇怪,明明php版本为5.4,为什么校验就不能通过呢?小编帮这位朋友联系了他们空间商,并把php版本更换为了5.3,尝试重新验证,竟然成功了。

小编这一头汗水,只能说要么这个插件自身有问题,要么空间有问题。这个问题也给大家提了一个醒,php版本并不是越高越好,选择一个适合的php版本,才是最明智的。

无忧主机相关文章推荐阅读:
DISCUZ!微信砍价插件500错误解决方法
DISCUZ根目录出现.$MOD.’.PHP文件解决办法
DISCUZ积分交易系统积分活动异常BUG修复方法

本文地址:http://www.51php.com/discuz/20481.html

喜欢本文或觉得本文对您有帮助,请分享给您的朋友 ^_^

阅读本文的人还阅读:


搜索技术文档