香港独立IP空间
香港php空间
美国php空间
域名注册

今天无忧主机小编接到一个dz论坛用户,他在论坛应用中心安装“qq群展示系统”插件的时候,提示“无法运行通过zend加密的应用”(如下图),这个无忧小编折腾了好久,都找不到原因,虚拟主机服务器明明支持zend,而且zend服务是正常服务的,就是无法解决,后来请找公司技术主管帮忙, 终于把问题搞清楚了。下面无忧小编把寻找这个问题的思路总结下,分享给大家。

 

zend 150x150 解决discuz安装插件提示“您的网站无法运行通过zend加密的应用”的问题

zend

首先出现这个问题肯定就是跟zend的加密有关。下面就从无忧小编就从zend着手分析

 

1.PHP版本的问题

空间环境导致zend加密出现问题。php5.3php虚拟主机主机环境,选择php5.2的插件版本就有可能会出现这个问题,因为PHP5.3zend加密模式跟PHP5.2算是不同的两个版本了。

 

2.插件版本的问题

dz的一些特殊应用的插件分为了php5.2php5.3版本,以满足不同php环境应用的论坛用户选择安装。 如版本选择安装错误。如php5.2的环境选择了php5.3版本的插件。而恰巧这个插件是需要调用zend加密的话,就会出现这个问题,这个和原因1本质是一样的。

3.dz版本和插件版本兼容性问题

dzgbkutf8big5(繁体)各种版本。dz的插件也会分为兼容dz论坛版本,也会有gbkutf8之分。而有的插件作者只提供该插件gbk版本的插件。本文中介绍的报凑,也是由于插件版本和论坛版本不兼容引起的。

总结:

我们在选择安装什么类型的插件的时候,需要程序版本号(含版本编码),插件版本号(含插件编码)都要一致,才能正常兼容安装,否则就会报错。

 

本文地址:http://www.51php.com/discuz/13011.html

喜欢本文或觉得本文对您有帮助,请分享给您的朋友 ^_^

阅读本文的人还阅读:


搜索技术文档